band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers band-of-brothers

forumhead
Forum >> Support >> Our Services » No Stat transmission
Sort:      «  1 2 3 4 5 6 ...  » printview
Senior Aircraftman
44 Posts
Enlisted On: 13.10.2016

[LS] Rangers
26.11.2016, 19:19 

Today my stats were not transmitted again. In the last few days (Monday, Tuesday, Thursday) it worked for me, but today not a single round was transmitted. They were very good rounds, so this is especially annoying unhappy
Senior Aircraftman
44 Posts
Enlisted On: 13.10.2016

[LS] Rangers
26.11.2016, 20:04 

The gulf of Mman server is not transmitting either. I just tested it on Battlelog Infantry and I got the points immediately after the round, so this issue must be related to your services.
Administrator
3262 Posts
Enlisted On: 31.01.2016

[LS] Rangers
26.11.2016, 22:11  Homepage

Hello SW01_DarK,

the stats go into a queue at battlelog.co; it's entirely possible that the snapshots coming from the official Servers get the priority wink even though, this issue seems to go on for days or hours right?

Staff Officer Italy S_h_a_r_k_93 

https://i.imgur.com/iwPUBn7.png
  All my contacts, social media and more!    shark.lost-soldiers.org
Senior Aircraftman
44 Posts
Enlisted On: 13.10.2016

[LS] Rangers
26.11.2016, 23:25 

I also played on SUPER@Airmaps and there the points were transmitted immediately as well, so I don't think they are prioritized. The really strange thing is that this happens only on certain days, mainly when I have really good rounds unhappy I don't understand this at all, but every other Server works all the time so I doubt this is account-related.
Moderator
421 Posts
Enlisted On: 12.10.2016

[LS] Rangers
26.11.2016, 23:49 

Okay this are my observations:

- the problem occurs only on some days (1-3 days in a week)
- the problem affects only some players

SW01_Dark played with me today evening on your Wake server. My points were transmitted without problems, whereas his points were not transmitted. Same on the Oman server. We switched to some other servers (Battelog EU2, Battlelog US infantry, Super@ S2), all the points were transmitted to our Battlelog accounts. Then I rejoined your Wake server for some matches and suddenly there was no point transmission for me, neither to my Battlelog acc nor to your Server Stats (last battle: 26.11.2016 - 20:56, which was the moment we switched the servers; but after the return I played on your server until Shark rebooted it because of a China squad bug at approx 23:45 pm)

Our mate SW02_Destroyer played with us yesterday, Dark's and my points were transmitted, not SW02_Destroyers's points. And they are not gonna be added to the profiles at a later time.

Hope this information can help you to solve the problem smiling
Cheers
Administrator
1984 Posts
Enlisted On: 30.01.2016

[LS] Rangers
28.11.2016, 20:11 

Firstly Laugh @ Dark's new Profile Picture

Thank-you both Dark & Carbon for following up on this and sharing your observations, this is now my #1 Priority to resolve currently. I have asked again (and several times now) for help from the Battlelog Staff, but they have their own priorities so I can only wait.

Dark, I feel like you don't fully understand how the Stats system works and you are being very quick to throw all of the blame at us - when this is not necessarily the case, so I will explain to you how everything comes together.

During the course of a round, a Snapshot file is produced by certain Python files on our server. This snapshot contains all of the info to enter into the Battlelog Stats Backend and is sent to Battlelog + Our Private Stats System at the end of the round. Whilst for us it is processed immediately, at Battlelog it can also enter a processing queue so it may not be immediate. You can see whether a snapshot has been received at the end of a round here: https://battlelog.co/snapshot_log.php

Our snapshots are always being received and recorded in this log. What that leaves us is two possible causes for your Stats not updating:

1) Battlelog's Backend is not able to process the Snapshot (or your part of it) because there is a bug/issue in our Python files which are creating the Snapshot, leading to issues in the Snapshot code itself.

2) Our Snapshots are fine but there is a bug/issue in the code of Battlelog's Backend for Stat-Processing which is causing it to fail when it comes to processing the Snapshot.

I'm going to have a look at our Python files now and compare to those which I received from Viper @ Weekend Warriors. I have also asked Mike from Battlelog to send me clean/latest Python files to use but haven't heard back yet so can't give an ETA.

If this is not the issue, then it is up to the Battlelog staff to identify why certain Snapshots are not being processed correctly and I can't give any ETA on when/if they will fix this. I realise how frustrating it is to generate big scores and not have them added to your stats. This has happened many times to me before on servers which were not correctly configured or crashed during a round (although never on our servers).

As Battlelog's Stats backend was originally based on the one we are using for Private Stats (which as you know has issues) it's quite possible that they haven't worked out all of the kinks yet, although Mike did tell me they have done a lot of work on improving it since then.

Cheers,

5tarLine

https://www.lost-soldiers.org/images/lsts.gif
Thanks
1
Given By: SW03_Carbon
Senior Aircraftman
44 Posts
Enlisted On: 13.10.2016

[LS] Rangers
28.11.2016, 21:34 

Thank you very much for your answer Starline, good to know that this is being worked on. I actually do know how the Snapshot system works and I am aware of the snapshot status-site, I also check it regularly.

This is by no means an accusation from me, I am only viewing the facts and it is fact that the Stats processing works on every other Server all the time, Battlelog or not. So it is only logical to come to the conclusion that there is something wrong with your system. And if the snapshots are lined up in a queue it would mean the stats are transmitted at a later time or date, but this is not the case, as even after weeks they are not appearing.

I have the theory that everyday only a percentage of the players on your Server are processed, as on some days my stats are transmitted as normal. I suppose that the majority is simply not noticing this. The reason for this behaviour is beyond me, and I would need to have a in-depth look at the system files to make any kind of sense from that.

Thanks for your efforts

Dark
Senior Aircraftman
44 Posts
Enlisted On: 13.10.2016

[LS] Rangers
03.12.2016, 20:33 

Today the points were not transmitted, again. It seems this occurs more often on weekends. Do you have any news regarding this issue, Starline?
Administrator
1984 Posts
Enlisted On: 30.01.2016

[LS] Rangers
06.12.2016, 23:47 

Sorry for the slow replies on this, work has been busy this week. I've investigated as best as I can but only found a small tweak to be made in one of our Python files. I doubt this will fix it, but who knows.

https://s12.postimg.org/ivfhpnz1p/dis.png

If anyone can work out why this is occurring, I have faith this man can OK

https://www.lost-soldiers.org/images/lsts.gif
Administrator
3262 Posts
Enlisted On: 31.01.2016

[LS] Rangers
07.12.2016, 20:36  Homepage

Well at least he replied something!!! Laugh
I must say I don't track my stats that much after all.

So here we're talking about battlelog.co stats as well as our private stats not being updated at the same time as battlelog ones, right? I mean, when this issue occurs (to some of the Players), does it happen on both stats systems? Battlelog and ours.

If so, it may mean that snapshot was not even produced correctly, perhaps it was discarded? I think it should be like that given the fact that both systems do not receive the points - if proven by your tests, SW01_* Players - cause I'd think it's unlikely that a trasmission error would occur between our game server and our stats server ... But I am not really into this thing so I don't really know what I am talking about: just food for thought. smiling

Staff Officer Italy S_h_a_r_k_93 

https://i.imgur.com/iwPUBn7.png
  All my contacts, social media and more!    shark.lost-soldiers.org
Sort:      «  1 2 3 4 5 6 ...  » printview

To Start Or To Reply To A Topic You Must Be Enlisted And Logged In!
Enlist Now
Login
Page Generated In 0.269643 Seconds

      Valid CSS!     Valid XHTML 1.0 Transitional
loading enlist enlist_hover lost_pw_hover mo08 mo10 mo12 mo14 mo16 mo18 mo20 mo22 mo24 mo26 up up2 registerheader